6.4 HPFP help needed

skevac

Member
Joined
Apr 22, 2012
Messages
132
Reaction score
0
Location
Michigan
My HPFP went out on Saturday. On top of the fact that I knew it was going to be expensive to fix apparently the pumps are very hard to come by. Does anyone know if a Navistar HPFP is the same and will work in the Ford application. Not sure that they are anymore readily available than the Ford ones, but am looking for any avenue to get my truck back on the road sooner as this is my main vehicle. Any help or suggestions would be appreciated.
 
Joined
Oct 15, 2017
Messages
71
Reaction score
2
Location
B.C Canada
Yes the maxxforce7 pump is interchangeable but is usually a bit more than powerstroke version. I've been told they outperform our pumps but never proved it so not sure I believe it.
 

Racer71

Member
Joined
May 23, 2021
Messages
50
Reaction score
8
Be ready to buy injectors, usually when the pump fails it takes the injectors out shortly after
 

DEEZUZ

Well-known member
Joined
Jun 30, 2011
Messages
6,524
Reaction score
81
Location
NWI
Good luck. I just installed the absolute last one in the entire country that I got from my supplier. And we've had 6 on emergency order from Ford for 6 months now.

Even though Ford remans we have had serious troubles with in the past
 

DEEZUZ

Well-known member
Joined
Jun 30, 2011
Messages
6,524
Reaction score
81
Location
NWI
Also curious on why you think "it went out"

Are you blowing fuse 74?
 

skevac

Member
Joined
Apr 22, 2012
Messages
132
Reaction score
0
Location
Michigan
Also curious on why you think "it went out"

Are you blowing fuse 74?
Glitter in lower filter housing. Truck stumbled then quit. Tried to restart it and it slightly ran for a few seconds and quit again. Tried to start it again and it timed out cranking. Now it won't even try to crank. Do you have an idea of why it won't crank? Could be a blown fuse, I haven't had time to investigate it much.
 

DEEZUZ

Well-known member
Joined
Jun 30, 2011
Messages
6,524
Reaction score
81
Location
NWI
Oh you need a system if you have the glitter.

That's injectors pump rails sensors lines filter base feed pump tank drop and clean.

You toast the starter?
 

skevac

Member
Joined
Apr 22, 2012
Messages
132
Reaction score
0
Location
Michigan
Is it hydrolocked?
Starter doesn't click or anything. I highly doubt trying to start it only twice would fry the starter, but who knows. I'm guessing a blow fuse or something in the PCM is telling it not to try. I really don't know and haven't had the time to look into it much.
 

skevac

Member
Joined
Apr 22, 2012
Messages
132
Reaction score
0
Location
Michigan
Oh you need a system if you have the glitter.

That's injectors pump rails sensors lines filter base feed pump tank drop and clean.

You toast the starter?
Yes a system. All the rest of the parts are available except the HPFP.
 

DEEZUZ

Well-known member
Joined
Jun 30, 2011
Messages
6,524
Reaction score
81
Location
NWI
Starter doesn't click or anything. I highly doubt trying to start it only twice would fry the starter, but who knows. I'm guessing a blow fuse or something in the PCM is telling it not to try. I really don't know and haven't had the time to look into it much.
There is a 12ish gauge starter wire with a round bullet type connector by the passenger negative cable. Undo it and out 12v to the male side, this will bypass the ignition and pcm and should crank the engine over.
 

skevac

Member
Joined
Apr 22, 2012
Messages
132
Reaction score
0
Location
Michigan
There is a 12ish gauge starter wire with a round bullet type connector by the passenger negative cable. Undo it and out 12v to the male side, this will bypass the ignition and pcm and should crank the engine over.
Your suggestion to do this worked, so it's not hydro locked and the starter is fine. I just bumped it a couple of times.
 

DEEZUZ

Well-known member
Joined
Jun 30, 2011
Messages
6,524
Reaction score
81
Location
NWI
Sounds like a pats issue.

Can you check fuse 74 for me though in the fuse box
 

Latest posts

Members online

Top